Talk:CentOS

From ZoneMinder Wiki
Jump to: navigation, search

First, thanks a bunch to mudputty for putting this wiki page together. It was very helpful, especially since I had no other way of finding out which version of ffmpeg was supposed to be compatible with the latest release of ZM 1.23.3.

mudputty, I didn't see this wiki when I was embarking on my project to setup Centos 5, ffmpeg, and then ZM, so I proceeded with pretty much all defaults with Centos and even though I successfully configured/built/installed ffmpeg from latest trunk SVN, I fuddled around with trying to get ZM to compile with it for better part of a day before just getting frustrated and giving up. I then searched the forums and saw your post about this wiki.

I did a complete "make uninstall" of the latest ffmpeg and retrieved v11879 (the rev you recommend in your wiki) to a new dir (ffmpeg-prev). I ./configure 'd it, although I used the following configure options:

./configure --enable-gpl --enable-shared --enable-libmp3lame --enable-libvorbis --enable-libamr-nb --enable-libamr-wb --enable-libxvid --enable-nonfree

Yes, I had to go through the long process of making sure all these other optional packages were installed like lame, ogg/vorbis, amr-nb/wb, xvid, etc. because I wanted ffmpeg support for them, even though ZM doesn't necessarily need all that. configure went fine. make compiled ffmpeg without issues also. But when I go to do a "sudo make install", I get this:

make                    -C libavutil   install-libs
make[1]: Entering directory `/home/user1/repos/ffmpeg-prev/libavutil'
install -d "/usr/local/lib"
install -m 755  "/usr/local/lib/.49.6.0"
install: missing destination file operand after `/usr/local/lib/.49.6.0'
Try `install --help' for more information.
make[1]: *** [install-lib-shared] Error 1
make[1]: Leaving directory `/home/user1/repos/ffmpeg-prev/libavutil'
make: *** [install-libs] Error 2

I'm wondering, did you get this also? Could it be due to all the additional options I've enabled with ffmpeg?



UPDATE 2008/6/23:

Just FYI to everyone who saw my comments to mudpuddy's wiki page on Centos 5.1/ZM 1.23.3. I finally figured out the problem with "make install" of ffmpeg rev 11879, and I've updated the original forum post with my findings and how I fixed it.[1]

My installation of ZM v1.23.3 is now working fine with MPEG streaming using ffmpeg. I hope this helped someone else in the same situation.

Thanks again to mudpuddy for putting up this very helpful wiki page; and of course, to the creators of ZM for the most excellent open source project of all time.

Cheers,

-Jac

Documention works well for CentOs5.2

CentOS 5.1 documention works well for clean install of CentoOS 5.2 and ZM.

SciLinux

I'm currently running 1.28.107 on SL 7.1 with no problems. I've been using the CentOS instructions all along and they've worked on the SL distro exactly as expected. Biloxigeek (talk) 17:20, 12 November 2015 (UTC)